Page 1 of 1

A bug in Quatram Reports 1.1 using radio buttons.

Posted: Sun Jul 18, 2010 8:06 pm
by NingImport
A bug in Quatram Reports 1.1 using radio buttons.

Posted by Charles61 on August 12, 2008 at 1:33am

I found a bug in Quatram Reports 1.1 involving printing labels of radio buttons. I have a six groups of radio buttons. Each group has 6 buttons. i also have six check marks, which are independent of the buttons and 12 data fields.

I used Jan's suggestion for printing the labels of a group of radio buttons of a data field with the expression:

the label of button (the hilitedButton of group "RadioButtonGroup") of group "RadioButtonGroup"

for the five groups.

My expression was:

the label of button (the hilitedButton of group "Radio1") of group "Radio1"

Each group of radio buttons has the same code with a change in the name of the radio groups, group "radio2", etc.

When I click print a report, the first and second times it prints without any errors. The third time I get a message: "Group: bad object type". n each case, no new data was entered.

The reason I tried printing several times is because I was getting the error message for the sixth button after putting the code separately for each button and then running the program to see if the code was okay. I deleted the code for the sixth group of buttons. Then I got the results above: the first and printing fine but the third printing give the error message ("Group: bad object type").

I am using a Mac with OS 10.5.4. Has anybody else run into this problem? This type of problems reduces the possibility of using Quatram Reports 1.1 in an app.


Reply by Jan Schenkel on August 12, 2008 at 8:53pm

Hi Charles,

Generally speaking, if it works for 5 groups, then it ought to work for the sixth group - so there must be a difference somewhere... As you're printing data from a stack, I'm assuming that the groups are part of a background and the data is stored over multiple cards?

All speculation, of course. If you would send me the stack and the layout file directly at, I'll have a look and see if I can replicate the problem and propose a solution.

Best regards,

Jan Schenkel
Quartam Reports & PDF Library for Revolution


Reply by Charles61 on August 12, 2008 at 9:29pm

Hi Jan!

There is only card in my stack. I did find that the error: Group: bad object type occur less when I close QR Builder. Then I tried printing I got the error on a sporactic basis. With an actual standalone, I am not getting the error! So, maybe it has to do with QR running?